perl Class::HPLOO 模块安装

由于安装DBD模块需要Class::HPLOO模块,但Class::HPLOO模块是在perl 5.028000版本写的,利用cpan或者cpanm均会出现问题,需要手动安装,在metacpan网站下载这个模块,手动安装,但还是会出现问题,“ Can’t use ‘defined(@array)’ ”,新版本的perl不支持”defined @”这个语法,去掉“defined ”就可以了。在“lib/Class/HPLOO/Base.pm”和“lib/Class/HPLOO.pm”这两文件中“defined @”的地方去掉”defined “,在“test.pl”这个文件中,将eval { require “test/classtest.pm” } ;” 替换成 “eval { require “./test/classtest.pm” } ;”,然后编译安装就可以了。

 perl Makefile.PL && make && make test && make install

参考资料:

perl模块Class::HPLOO v0.23安装问题

perl module Class::HPLOO v0.23 install issue

发表回复

您的电子邮箱地址不会被公开。